Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 02, 2026 - 12:30 PST
Scheduled
Dear LiveWorld Platform Customer,
We will deploy a patch to the LiveWorld platform today, Monday March 2nd 2026 at 12:30pm PT / 3:30pm ET for improved YouTube content retrieval.
We do not anticipate any downtime, and will notify you again when the deployment and verification is complete.
Sincerely, LiveWorld Software
Posted Mar 02, 2026 - 11:50 PST
This scheduled maintenance affected: Social Media API (back end) (API communication (receiving data), API communication (sending data)) and Web Platform (User Interface / Front End).