Microsoft Outlook/Exchange outage

Incident Report for LiveWorld Platform

Resolved

Microsoft services have restored based on their update.
Posted Nov 25, 2024 - 19:09 PST

Investigating

Microsoft is experiencing an outage that includes Outlook, Exchange and Teams. Please expect delays in emails being sent/received.
Do use Slack and phone for urgent issues.

https://x.com/MSFT365Status/status/1860973220662280356
Posted Nov 25, 2024 - 11:45 PST
This incident affected: Social Media API (back end) (API communication (receiving data)).