Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 30, 2026 - 16:00 PDT
Scheduled
Dear LiveWorld Customer,
We will deploy an update to the LiveWorld platform tomorrow, Thursday, April 30, 2026, at 4pm Pacific (6pm Central, 7pm Eastern). The release and follow-up verification will take approximately 1 hour.
We anticipate no downtime during the release process.
Thank you, LiveWorld Software
Posted Apr 29, 2026 - 15:45 PDT
This scheduled maintenance affected: Social Media API (back end) (API communication (receiving data), API communication (sending data)) and Web Platform (User Interface / Front End).