Dear LiveWorld Customer, The release and verification are complete: The LiveWorld platform is updated and ready for your use. Release notes will be available soon on https://help.login.liveworld.com/, where a new Link, labeled "Release Notes for May 2025" will appear at the top of the "Release Notes" category. Sincerely, LiveWorld Software
Posted May 29, 2025 - 20:54 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 29, 2025 - 19:00 PDT
Scheduled
Dear LiveWorld Customer,
We will deploy a new release of the LiveWorld platform on Thursday, May 29, 2025 at 7:00pm PT (9:00pm CT, 10:00pm ET).
Release notes detailing the enhancements and bug fixes in this release will be available on help.login.liveworld.com after the release is complete and verified.
During the release, there may be up to 60 minutes of downtime. After the release is complete, we will perform necessary verification tests.
We will notify you before the release begins and after verification is complete.
Let us know if you have any questions.
Thank you, LiveWorld Software
Posted May 28, 2025 - 15:22 PDT
This scheduled maintenance affected: Social Media API (back end) (API communication (receiving data), API communication (sending data)) and Web Platform (User Interface / Front End).